03 августа 2008

Dlink DWA 140

Потребовалось срочно раздать инет с компа (в перспективе - с любого) на один девайс, девайс умеет wi-fi. Пролистал прайсы местных магазинов, увидел сабж, пошукал по гуглю, как оно работает под линем. Нашёл на каком-то убунтушном форуме хауту по настройке. Купил, с поправкой на генту завёл (via ndiswrapper), сделал нат-маскарад. Работает. Попробовал то же организовать под виндой - и не смог. Бестолково там как-то всё. Завелось на минуту и отпало.

8 комментариев:

dmig комментирует...

у меня dwa-120, с ним похожая история: в винде соединение установить (да и вообще увидеть сети) возможно только через утилиту от d-link. в линуксе те же самые драйвера работают без проблем.

PhoeniX комментирует...

ну не, сейчас-то везде где надо я и под виндой это завёл, но как-то там всё равно всё бестолково.

Роман комментирует...

работает только через ndiswrapper?
родной линуксовый драйвер не пробовали?
вроде, он не так давно обновлялся.
если пробовали - отпишите, пожалуйста, я тоже подумываю о покупке этого устройства.

PhoeniX комментирует...

есть нативный? ткните носом, попробую. а то сейчас оно раз в сутки отваливается как-то странно - сеть есть, wlan девайс есть, а пакеты им не принимаются (TCP).
С другой стороны я сразу всё настроил на автоматику - воткнул - подгрузился драйвер, поднялась сеть.

PhoeniX комментирует...

кстати, если нет необходимости именно таскать эту штуку с собой - купите точку доступа. С адаптером можно построить только одноранговую сеть, а значит там будет только wep, которым только кур смешить в наши дни

Роман комментирует...

если правильно понял, dwa 140 сделан на чипе Ralink RT2870. драйвера от Ralink обновлялись в мае. смотреть тут http://www.ralinktech.com/ralink/Home/Support/Linux.html

rbuilder комментирует...

собирал сегодня ядро 2.6.30.1 там есть такой пункт:

Ralink 2870 wireless support RT2870

This is an experimental driver for the Ralink 2870 wireless chip.

PhoeniX комментирует...

надоело всё, взял и сделал оверлейчик вот этого http://bugs.gentoo.org/show_bug.cgi?id=228553
завелось, буду тестить